Electronics > FPGA

Xilinx ISE在Ubuntu上

(1/2) > >>

亚历克斯·惠特莫尔:
有人成功在Linux下安装了Xilinx ISE 13.1吗?具体来说,我'我试图将其安装在Ubuntu 10.10 VM中。一切都进行得很顺利,直到尝试安装电缆驱动程序为止,而这只是左右失败。

如果您也有有关如何安装Digilent电缆插件的提示,则可加分'是我的Digilent董事会'm实际定位。其实我'm仅尝试安装Xilinx电缆驱动程序,因此iMPACT不会'每次启动时都不要抱怨。

易碎:
我实际上是在Xubuntu 10.10下将它带回家的,但是我认为'是较早的版本。  I'待我回家后再检查...

亚历克斯·惠特莫尔:
At this point I'm愿意降到12.x。一世'd显然喜欢最新和最伟大的产品,但Digilent不喜欢'谈不上支持13.x的任何事情,所以我还是不得不这么做。如果您还记得如何,我'd love to hear.

mikeselectricstuff:
从我听到你真的不知道'想要最新版本的ISE ...我've seen words like 'crisis'在赛灵思状态下使用'的软件工具...

易碎:
这是我关于WebPACK 12.4的安装说明:

假设使用XUbuntu 10.10和Nexys2板(Spartan 3E,-4速度,FG320封装)

安装一堆支持包

>须藤apt-get install libusb-dev libusb-1.0
>须藤apt-get install libstdc ++ 5 libmotif3 libxp6 libcurl3
>sudo apt-get install build-essential
>须藤apt-get install fxload libftdi1

安装WebPACK:

>焦油xvf Xilinx_ISE_DS_Lin_12.4_M.81d.2.0.tar
>光盘Xilinx_ISE_DS_Lin_12.4_M.81d.2.0
> sudo bash ./xsetup


*默认为安装"ISE设计套件:系统版"。你当然是阿伦'成为百万富翁,所以你'll install the free "ISE WebPACK"
*你'将必须获得许可证(免费)并安装电缆驱动器
*允许其安装到/opt/Xilinx/12.4
*去喝咖啡-需要一段时间
*它会连接到internetz并为您获取许可证。
生成并安装urjtag 0.10

您需要此功能,但不幸的是,Ubuntu提供的版本较旧(0.0)-用途不多。
Get it from http://www.urjtag.org/

标准的东西...

>tar zxvf urjtag-0.10.tar.gz
> cd urjtag-0.10
> ./configure
> make
> sudo make install

安装Digilent Nexys2驱动程序:

Get it here: http://www.digilentinc.com/Products/Detail.cfm?NavPath=2,66,828&Prod=ADEPT2

>tar zxvf digilent.adept.runtime_2.5.1-i686.tar.gz
>cd digilent.adept.runtime_2.5.1-i686
>须藤bash ./install.sh

>tar zxvf digilent.adept.utilities_2.1.1-i686.tar.gz
>cd digilent.adept.utilities_2.1.1-i686
>须藤bash ./install.sh

>cd /opt/Xilinx/12.4/ISE_DS/ISE/lib/lin/plugins/
> sudo mkdir Digilent
> cd Digilent
>须藤mkdir libCseDigilent
>cd〜/ gzip_file_location
>焦油zxvf libCseDigilent_2.0.3-i686.tar.gz
>cp libCseDigilent_2.0.3-i686 / ISE12x / plugin / * /opt/Xilinx/12.4/ISE_DS/ISE/lib/lin/plugins/Digilent/libCseDigilent

导航

[0] 讯息索引

[#] 下一页

感谢时出现错误
谢谢...
转到完整版